JORAM/JoramMQblue arrow Incompatibilité de Licences
Author Messages

pbr@thales

Member since
09.07.2012

1 post

point 09.07.2012 at 17:03:34

bjr,

Nous avons passé l’outil Black Duck (contrôle de l’inter-compatibilité des licences open sources) sur une application qui met en oeuvre Joram.

Black Duck signale une incompatibilité entre licences, due au fait que l’on intègre des composants distribués sous licence LGPL 2.1 (Joram) et d’autres distribués sous Apache 2.0. Apparemment la licence LGPL 3.0 serait pour sa part compatible avec Apache 2.0

Y a t il une solution pour utiliser Joram avec des OSS distribués sous Apache 2.0 ?

serge

Member since
09.10.2012

4 posts

point 09.10.2012 at 10:20:39

hi pbr,

you raise a licensing compatibility issue between JORAM (LGPL V2.1) and other Apache 2.0 components you associate JORAM with. I do not understand this, which must be juridically quite technical, but I take it on faith from Black Duck.

We have just had a close look to this licensing issue you raise.
Actually most of JORAM code is licensed under "LGPL V2.1 or later". A few other secondary files do not comply with this so we have fixed them so that next version 5.8 will be fully LGPL V2.1 or later.

This means that you will be able to use JORAM V5.8 under LGPL V2.1 or V3.0 at your choice, solving this compatibility issue.

reply
go back

forum reply


Forum registration required

Prior to participating in this forum, you must register. Thank you for entering the personal identifier supplied to you. If you are not already registered, you must register.

[login] [register] [password forgotten?]